ESRI Performance Issues

Incident Report for Tablet Command

Resolved

ESRI has resolved this issue as of approximately 1005hrs Pacific time.
Posted Jun 26, 2025 - 10:20 PDT

Update

In our investigation we have found that the standard ESRI basemaps are still loading. The issues seems to only be affecting User Maps. Tablet Command Users can select those standard basemaps to at least have a basic map.
Posted Jun 26, 2025 - 09:20 PDT

Monitoring

ESRI performed maintenance last night and they are currently reporting performance issues on their status page. We have had reports from at least one customer that their maps are blank.

All Tablet Command services are operating normally.

For updates you can visit the ESRI status page at this URL:

https://status.arcgis.com
Posted Jun 26, 2025 - 09:08 PDT